REQUEST A CALL

ArchiOffice - System Requirements

For successful installation and implementation of your ArchiOffice software, your computer system must meet or exceed the minimum requirements below. System requirements are different for Servers and Clients, and depending on whether you are using Windows or Mac operating system.

Server Requirements

Hardware Requirements

  • Any Intel x86-compatible microprocessor (Intel i3 or later recommended)
  • 2 GB RAM or more (4 GB recommended)
  • At least 20 GB of free hard disk space required

Software Requirements

  • Windows Server 2012, Small Business Server 2011 or 2008, Windows Server 2008, Windows 10, Windows 8 Pro, Windows 7 (Professional, Enterprise or Ultimate)
  • Windows Server 2012 Essentials/R2 Essentials editions do not support SQL Server and hence ArchiOffice 2016 cannot run on those operating systems.

    ArchiOffice 2016 is now a full 64-bit application and must be hosted from a server running a 64-bit version of Windows.

  • Microsoft .NET Framework 4.5 (installed automatically by our installer)
  • Internet Information Server (IIS) 7.0 or later (IIS is part of Windows; needs to be installed and configured properly by a Windows administrator)
  • SQL Server 2014/2012/2008 Standard or Express Edition with Management Tools
  • Internet connection
  • For Mac only users: Virtualization software like VMWare or Parallels, and Microsoft Windows OS (See Set Up Mac for ArchiOffice 2016 for more)

It is highly recommended that firms with more than 5 users should use Windows Server 2008/2008 R2/2012 instead of Windows 7.


Client Requirements

Hardware Requirements

  • Any Intel x86-compatible microprocessor (Intel i3 or later recommended)
  • 2 GB RAM or more (4 GB recommended)
  • At least 5 GB of free disk space required
  • For Mac users: An Intel processor, 4 GB of free disk space, 2 GB or better RAM

Software Requirements

  • Windows 10/Windows 8/Windows 7 or Mac OS 10.7 or later
  • Microsoft Internet Explorer 9.0/10.0/11.0, Chrome 7.0 to 34.0, Firefox 10.0 to 27.0, Opera 11.0, Safari 7.0 or later
  • Google Chrome is the recommended browser for ArchiOffice since it is easier to configure in terms of turning off popup blocker and clearing the browser cache. However, ArchiOffice works with other browsers too as long as the pop-up blocker settings are set correctly.

  • Latest version of Java 8
  • ArchiOffice 2016 uses Java to open project documents and for data synchronization with Microsoft Outlook and QuickBooks.



Be sure to install the latest Windows service packs and critical updates. Check the Microsoft web site for the latest updates to Windows, .Net Framework, and Data Access Components. Some versions of Windows include an Automatic Update option.